Friday, September 19, 2008

Changing the Bitmap Banner in Visual Studio 2005 Setup Projects

If you have created a setup project in Visual Studio 2005, and you want to change the banner that appears on every setup screen - you'll soon find that it's not easy to do. Firstly, you need to override the BannerBitmap setting on every screen, and secondly by default it likes to have the picture you want to use to be installed on the target computer.

However, it doesn't have to be that way. Thanks to a MSDN Forum post by René van Bemmelen, the answer is really simple.

First, create you banner image as a bmp or jpg and save it somewhere. The size of the image should be 500px by 70px.

Secondly, if you typically setup your projects localised to "English (United States)", then go to the directory:

C:\Program Files\Microsoft Visual Studio 8\Common7\Tools\Deployment\VsdDialogs\1033

And make a backup copy of the file VsdUserInterface.wim. If you localise to one of the other languages then you'll need to work out what directory you should be working in.

Thirdly, open the file VsdUserInterface.wim in your favourite MSI editor. This could be either Orca (from the Windows Installer SDK), or you could download InstEd from http://www.instedit.com/.

image

Select the Binary table and double-click the data entry for the DefBannerBitmap entry. If you click on the ... button to the right, you can then select the banner image that you created earlier.

Lastly, select the left arrow button to load the image into the wim file. Don't forget to save the updated file!

This change means that all MSI's that you then build from Visual Studio will have this banner as the default.

7 comments:

Anonymous said...

Great tip! Now I can have my company's logo as the default without having to update it on every screen.

Anonymous said...

Great ! Thanks !

(French directory is : 1036)

Tom Tech Blog said...

For Visual Studio 2008 the path is C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\Tools\Deployment\VsdDialogs\1033

Anonymous said...

Perfect! Thank you very much.

Stanny said...

thx, very usefull!

vikaspandey013 said...

I followed the way you suggested and rebuild-ed the setup project still no effect of my image.old image only is getting reflected.

Any suggestions..

Dean Heard said...

@vikaspandey013 - most likely it's the localisation you are building as, this determines which file you need to modify.